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LAB 1: Introduction to Unified Modeling Language (UML) and Visual Paradigm 

for UML Software as a CASE* Tool 

 

 

OBJECTIVES 

� Introduction to UML notations and diagrams. 

� Hands on exposure of “Visual Paradigm software for UML” involving analysis and 

design with UML diagrams. 

 

 

 

INTRODUCTION 

 

Definition of Unified Modeling Language (UML) 

 

� UML is a standard language for specifying, visualizing, constructing, and 

documenting for large software systems, as well as for business modeling and other 

non-software systems. 

� Considered a very important part of developing object oriented software and software 

development process. 

� UML uses graphical notations to express design of software projects and its 

requirements. 

 

 

Common Types of UML Diagrams 

 

UML defines several types of diagrams: class (package), object, use case, sequence, 

collaboration, statechart, activity, component, and deployment. 

 

Type Description Diagram Display 
Use Case Diagram 

 

Use case diagrams model the 

functionality of system using actors 

and use cases. 

 

 

* Computer Aided Software Engineering 
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Class Diagram 

 

Class diagrams are the backbone of 

almost every object oriented method, 

including UML. They describe the 

classes of the system, their inter-

relationships, and the operations and 

attributes of the classes. 

 

 
Object Diagram A diagram that shows a complete or 

partial view of the structure of a 

modeled system at a specific time. 

They can be used to test class 

diagrams for accuracy. useful for 

exploring “real world” examples of 

objects and the relationships between 

them 

 
 

Sequence Diagram Sequence diagrams describe 

interactions among classes in terms of 

an exchange of messages over time. 

 

 
Interactions 

Diagram 

 

Represent interactions between 

objects as a series of sequenced 

messages. Collaboration diagrams 

describe both the static structure and 

the dynamic behavior of a system. 

 
Modified after: http://www.smartdraw.com/resources/tutorials/Introduction-to-UML 
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USING Visual Paradigm for UML (VP-UML) 

 

Launching VP-UML and Workspace Configuration 

 

 
 

� To activate an instance of VP-UML: 

In windows desktop, highlight and click “START > Visual Paradigm > Visual 

Paradigm for UML 7.1 Standard Edition”. 

 

A workspace launcher will be displayed when VP-UML is started: 

 It is recommended to set your workspace path in your Documents folder. 

 

 
The workspace launcher dialogbox 
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If you want to disable the workspace launcher from appearing again, check “Use this as 

the default and do not ask again” at the bottom of the window box.  

This will cause the VP-UML to automatically open the selected workspace next 

time. 

 

Please note that a Workspace is an important directory which stores all your project 

settings / configurations, diagrams and reports / analysis. 

 

 

Importing an (existing) workspace 

 

VP-UML also allows the import of an existing workspace, usually the case when such 

workspace is located elsewhere, or existed previously. To do this, click the “Import 

Workspace” button to launch another dialog box. 

 

The path of the existing workspace can be defined in the dialog as shown below: 
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Interface Overview 

 

  

No Name Description 

1 Menu and Toolbar Options for configuration, editing and execution. 

2 Diagram Navigator Various explorers placed here for accessing project 

data from different domains and listing of 

diagrams. 

3 Various Auxiliary Panes Auxiliary panes displaying panes like property 

pane, preview pane, documentation pane and 

stencil pane shown here. 

4 Diagrams Pane / Analysis 

Pane 

Diagrams are displayed in this frame. Reports or 

analysis are also shown here. 

5 Message Pane Messages generated by various operations 

displayed here. 

 

 

 

 

 

 

1 

2 

3 

4 

5 
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Menu Toolbar 

 

Menu Toolbar> File Menu 

 

The File Menu in short allows project and file control 

features: 

� Create a project 

� Create a diagram 

� Open and saving of projects 

� Project Template related operations (Saving 

and Maintenance) 

� Import of project data from different UML 

software file formats 

 

 

Menu Toolbar> Edit Menu 

 

The Edit Menu enables: 

� Undo and Redo 

� Cut or Copy 

� Select everything in a diagram 

� Jump to a diagram or an element 

� Grouping 

� Shapes alignment and distribution 
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Menu Toolbar> View Menu 

 

The View Menu enables: 

� Show / hide a pane 

� Show and manage grid 

� Management of layers 

� Zoom diagram in and out 

� Manage nickname and style 

 

 

Menu Toolbar> Tool Menu 

 

The Tool Menu allows: 

� Generation of reports 

� Publish project 

� Perform use case scheduling 

� Open various kinds of element grid 

� Configure requirements 

� Configure programming language 

� Perform Integrated Development Environment 

(IDE) integration 

� Perform Teamworks operation 

� Management of shapes through Shape Editor 

� Management of license keys 

 

 



 

TU2943: Information Engineering Methodology Lab Notes, 2009-2010, 

Faculty of Technology and Information Science, 

Universiti Kebangsaan Malaysia 

  

 

Nor Samsiah Binti Sani   8

Menu Toolbar> Window Menu 

 

The Window Menu enables: 

� Navigation between opened diagrams 

� Rearrangement of diagram windows 

� Switching to another diagram 

� Close diagram/s 

 

 

Menu Toolbar> Help Menu 

 

The Help Menu allows easy access to VP-

UML manual and online help. 

 

 

 

CREATING PROJECTS 

 

Each diagrams and model elements created in VP-UML must be defined within a project. 

To create a project, click under Menu toolbar, “File > New Project”, and a dialog box 

will pop out. 
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� Apply the following options as part of your project specification: 

� UML version : UML 2.1 

� Language  : Java 

� Project Name : Exam Registration System 

� Author  : <your_name> 

 

Note that for this lab conducted in UKM, Java is the preferred language, although 

any language integration (with VP-UML) is possible. 

 

� Press the “Create Blank Project” button when done. 

 

 

Creating projects by Project Templates 

 

 
 

Some users who have been using VP-UML for some time may have their own 

preferences when creating a new project. For example, he might want to have at least 10 

predefined Use Case diagrams in each of his new project.  

 

To allow this, a project template can be defined to be used later when creating a new 

project. 

� To create project from template, select the Template page and select “Sample 

Template”, then click “Create from Template” button. 

Notice that your project will have each 1 Use Case Diagram, Class Diagram, 

Sequence Diagram and Activity Diagram compared to a blank project. 
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Creating projects by importing other CASE tool project 

 

 
 

For users wishing to migrate from other legacy projects with other CASE tools (e.g 

Rational Rose, AgroUML), those projects can also be imported into VP-UML. To do 

this: 

 

� Select the “Other CASE Tools Project” page, and select either Import from Rose to 

import a Rational Rose project (.mdl), or Import from XMI to import XMI file 

exported from the CASE tool.  

� Click “Create from Other CASE Tools” to import the project. 

 

 

Saving Projects 

 

Visual Paradigm for UML saves all project content to a single file, with file extension 

.vpp. 

 

 
 

To save a project, select under Menu Toolbar, “File > Save Project”. The first time you 

save the project will cause the Save Project dialog box to appear (shown above). 
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Note that you can also save your project either in your predefined workspace or a specific 

directory. 

 

Saving project > to Workspace 

 

To save project to workspace, select Save to workspace. The project file will be saved in 

the workspace directory, as shown above. 

 

Saving project > to Directory 

 

To save project to a specificed directory (other than workspace default path), select “Save 

to Directory” and specify the direction path in the “Direction” field. 

 

 
 

 

CREATING, DELETING AND MODIFYING DIAGRAMS 

 

You can create a diagram in a number of ways: 

� Using toolbar; 

 
 

 

 

 

 

 

 

 

 

Diagrams Shortcut Icons 
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� Using new diagram dialog box; 

 
 

 
 

� Or, Using popup menu of diagram navigator. 
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Similarly, you can also delete a diagram in the diagram navigator. To do this, create a 

diagram first by: 

� Under the Menu Toolbar, click “File > New Diagram > UML Diagrams > Use 

Case Diagram” to create an empty Use Case Diagram. 

 

� Now highlight “Use Case Diagram1” by right clicking and click the Delete 

option. The diagram will be deleted. 
 

 
 

Also remember that you can rename your diagram at anytime, choose the “Rename” 

option instead of “Delete” to perform renaming of diagram. Try this. 
 

 
 

 

WORKING WITH DIAGRAMS AND ITS ELEMENTS 

 

To illustrate the usage of diagrams and its elements, we need to create a new diagram. 

We will use a Use Case Diagram for this (more of Use Case models to be covered in Lab 

2). For now, follow the steps below: 

 

� Under the Menu Bar, click “File > New Diagram > UML Diagrams > Use Case 

Diagram” to create an empty Use Case Diagram. 

 

Delete option 
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Notice that the Use Case Diagram Toolbar will be attached to the diagram pane which includes all 

elements of a use case.  

 

� Click the Actor symbol in the use case toolbar and click once again anywhere in the 

Diagram Pane. An Actor will be created. 

 

 
 

� Notice that in the Various Auxiliary Pane, the Property Tab highlights the created 

Actor item. You can also modify the property of the Actor here.  

Rename the Actor name as Student. 

 

Use Case Toolbar 
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 Property tab displaying highlighted element’s properties to edit properties such as Name. 

 

� Using the same methods when creating the actor above, try to produce a use case and 

associate it with the created actor. Detailed steps below: 

� Create a new Use Case and name it “Search for course module”. 

� Create an association and link the actor “Student” with use case “Search for 

course module”. 
 

 
 

� You should get a diagram shown below: 
 

 
 A simple use case diagram. 

 

� Now try to left click and drag the use case around and notice that the association will 

still preserve the relationship of both the actor and its use case.  

This allows for flexibility and modification in the design of the diagram. 

 

� To delete an element, several ways are possible. Try any one below: 

� Left click the use case “Search for course module”. Under Menu Toolbar, 

click “Edit > Delete”; OR, 

Various Auxiliary Pane 

Actor Association Use Case 
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� Left click the use case “Search for course module”. Then Press keyboard key 

“Delete”; OR, 

� Right click the use case “Search for course module”. Click on the “Delete” 

option. 

 

 

 
A dialog box will appear to ask for delete confirmation. If (AND ONLY IF) you want to 

disable deletion confirmation, tick the “Remember my choice and don’t ask again”. 

 

� As an exercise to familiarize yourself with VP-UML diagram activity, try to create a 

simple use case diagram as shown below: 
 

 
Use Case Diagram for a Student Exam Registration System Example 

 

Use Case Flow of Events: 

� Student search for a module from the database. 

� Student search for an examination from the database. 

� Student registers for an examination, which needs to search for a specific 

examination. 

� When student registers for an examination, the request of exam registration is 

processed and records updated into the database. 
 

Use Case Description 

Use Case Description 

Search for course 

module 

Provide a simple search functionality of courses which 

will be displayed in table format.  

Search for exam Provides a list of registered exams of the student to help 
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the student register for one / many exams. 

Register for exam A student can register for an exam. 

 

 

End of Lab 1. 


